Investigating Issue Impacting Conga Sign Professional

Incident Report for Conga

Resolved

After investigation, this is not a service-wide incident. The issues with resending transactions and the View Audit button have been confirmed as an intermittent product defect and are being addressed by Engineering as a high priority item. Affected customers should contact Conga Support for updates.
Posted May 14, 2026 - 21:20 UTC

Investigating

We are currently investigating reports of service impact affecting Conga Sign Professional within the NA region.

Customers may experience inability to resend transactions and the View Audit button not re-directing properly.

We will provide further updates as they are available.
Posted May 14, 2026 - 20:15 UTC
This incident affected: Conga Legacy Products - North America (NA) (Conga Sign Professional - NA).