Issue Identified with Multiple Products - Degraded Performance Due to AWS Outage

Incident Report for Conga

Resolved

AWS has resolved the service disruption in the NA (US-EAST-1) region. The affected Conga products have returned to normal operation.

If you continue to encounter any issues, please contact our support team.
Posted Oct 20, 2025 - 22:58 UTC

Monitoring

We are continuing to monitor the recovery of the AWS outage. AWS is reporting significant progress in restoring services, and we are observing corresponding improvements in our affected products.

Some Conga services may still experience intermittent performance issues or errors as the underlying infrastructure fully recovers. Our teams will continue to monitor the situation until all services return to normal operation.

AWS Health Dashboard: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 20:35 UTC

Update

We are continuing to monitor the ongoing AWS service disruption. While AWS reports that some services are recovering, the impact to Conga products remains limited and intermittent at this time. We will provide another update as more information becomes available.

AWS Health Dashboard: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 18:58 UTC

Update

We are continuing to monitor the AWS outage status.

AWS Health Dashboard: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 17:50 UTC

Identified

We have identified a service disruption with our cloud infrastructure provider, Amazon Web Services (AWS), in their NA (us-east-1) region.

This is impacting multiple Conga services, and customers may experience increased error rates and latency.

Our teams are actively monitoring the provider's status and will post updates here as they become available.

AWS Health Dashboard: https://health.console.aws.amazon.com/health/home#/account/dashboard/open-issues
Posted Oct 20, 2025 - 17:17 UTC
This incident affected: Conga Dependencies (AWS Cloud Platform), Conga Legacy Products - North America (NA) (Merge Service Legacy - NA), and Document Automation - North America (NA) (Conga Collaborate - NA).