The issue impacting Conga Batch in the NA region has been fully resolved and all affected systems have returned to normal operation.
Posted Jun 18, 2025 - 17:03 UTC
Monitoring
A fix has been implemented. Our systems are recovering, and we are now closely monitoring performance and stability to ensure the issue is fully resolved. Users should see performance returning to normal.
Posted Jun 18, 2025 - 16:27 UTC
Identified
We've identified the root cause of the issue impacting Conga Batch.
Our engineering teams are actively working on implementing a solution to resolve the issue.
Customers may continue to experience slow performance while the fix is being deployed.
Posted Jun 18, 2025 - 16:01 UTC
Investigating
We are currently investigating reports of degraded performance affecting Conga Batch within the NA region.
Customers may experience slow performance.
We will provide further updates as they are available.
Posted Jun 18, 2025 - 15:59 UTC
This incident affected: Document Automation - North America (NA) (Conga Batch - NA).