Investigating Issue Impacting Sign Professional

Incident Report for Conga

Resolved

The issue impacting Sign Professional in the North America (NA) region has been fully resolved and all affected systems have returned to normal operation.
Posted Sep 17, 2026 - 21:31 UTC

Update

The issue has been successfully remediated, and functionality has returned to normal. We appreciate your patience while we worked to resolve this matter.
Posted Sep 17, 2026 - 21:30 UTC

Identified

We've identified the root cause. Our engineering teams are actively working on implementing a solution to resolve the issue.

Customers may continue to experience slow performance while a fix is being deployed.
Posted Sep 17, 2026 - 20:58 UTC

Investigating

We are currently investigating reports of degraded performance affecting Sign Professional within the NA region.

Customers may experience intermittent errors or slow performance.

We will provide further updates as they are available.
Posted Sep 17, 2026 - 19:53 UTC
This incident affected: Conga Legacy Products - North America (NA) (Conga Sign Professional - NA).