Performance Degradation on Salesforce Core Services

Incident Report for Conga

Resolved

This incident has been resolved.
Posted May 22, 2026 - 04:36 UTC

Monitoring

Salesforce has done rolling restarts, released connections with pre-mitigation configurations, and currently performing final validations and taking proactive actions to ensure full remediation. With the Salesforce rolling restarts, all Conga Turbo services are operation, but we are monitoring the situation actively until Salesforce outrage is fully resolved.
Posted May 22, 2026 - 00:23 UTC

Update

Salesforce is still continuing to investigate the issue.
Posted May 21, 2026 - 23:24 UTC

Investigating

Salesforce Core services are currently experiencing performance degradation, which is intermittently impacting Turbo SFDC authentication.

This includes things like:

Authentication and login services
API endpoints
Database/platform infrastructure
CRM application backend services
Metadata and workflow services

We are closely monitoring the Salesforce outage and will provide updates as we learn more.
Posted May 21, 2026 - 22:03 UTC
This incident affected: Conga Legacy Products - North America (NA) (Turbo Search Service - NA, Turbo Pricing Service - NA, Turbo Config Service - NA) and Conga Legacy Products - EMEA (EU) (Turbo Search Service - EU, Turbo Pricing Service - EU, Turbo Config Service - EU).