Investigating Issue Impacting Composer

Incident Report for Conga

Resolved

The issue impacting Composer UI in the NA regions has been fully resolved and all affected systems have returned to normal operation.
Posted Nov 27, 2025 - 19:25 UTC

Investigating

We are currently investigating reports of degraded document merge performance affecting Composer within the NA region.

Customers may experience slow performance for document merges through the Composer Salesforce UI.

We will provide further updates as they are available.
Posted Nov 27, 2025 - 19:05 UTC
This incident affected: Document Automation - North America (NA) (Conga Composer - NA).