Investigating Issue Impacting Conga Sign Professional

Incident Report for Conga

Resolved

The issue impacting Conga Sign Professional in the EU and AP regions has been fully resolved and all affected systems have returned to normal operation.
Posted Mar 16, 2026 - 19:25 UTC

Monitoring

A fix has been implemented. Our systems are recovering, and we are now closely monitoring performance and stability to ensure the issue is fully resolved.

Services should now be accessible and functioning normally.
Posted Mar 16, 2026 - 19:15 UTC

Update

Our engineering teams continue to work on implementing a solution to resolve the issue. We're targeting a recovery within the hour.
Posted Mar 16, 2026 - 18:40 UTC

Identified

We have identified an infrastructure failure that is preventing access to the Sign service in the EU and AP regions.

Our engineering teams are currently deploying a fix to restore connectivity.

Customers may continue to experience access issues while this deployment is underway.
Posted Mar 16, 2026 - 17:42 UTC

Investigating

We are currently investigating reports of an outage affecting the Conga Sign Professional service within the EU and AP regions.

Customers may experience intermittent errors or an inability to access the application.

We will provide further updates as they are available.
Posted Mar 16, 2026 - 17:07 UTC
This incident affected: Conga Legacy Products - EMEA (EU) (Conga Sign Professional - EU) and Conga Legacy Products - APAC (AP) (Conga Sign Professional - AP).