Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 29, 2025 - 04:30 UTC
Scheduled
CCI Standalone and Discovery AI will undergo release deployment and infrastructure maintenance. During this maintenance window, you may experience potential service disruptions. We will provide you with timely updates throughout the maintenance process to keep you informed.
Posted Jun 27, 2025 - 13:59 UTC
This scheduled maintenance affected: Conga Legacy Products - APAC (AP) (Conga Contract Intelligence - AP) and Contract Lifecycle Management - APAC (AP) (Discovery AI - AP).