Conga Contracts – North America Performance Degradation

Incident Report for Conga

Resolved

The issue impacting Conga Contracts in the NA region has been fully resolved and system has been operating normally for the past 9 hours.
Posted Jul 22, 2026 - 07:14 UTC

Investigating

We are currently investigating ongoing performance degradation impacting Conga Contracts in the North America (NA) region.

Our Engineering team is actively working to identify the root cause and implement mitigations to restore normal service levels as quickly as possible.

During this time, customers may experience slower-than-normal response times and intermittent delays when using Conga Contracts.

We will continue to provide updates as more information becomes available.
For real-time updates, please monitor our status page: status.conga.com
Posted Jul 21, 2026 - 17:38 UTC
This incident affected: Conga Legacy Products - North America (NA) (Conga Contracts - NA).