We continue to monitor system performance and stability and are seeing continued improvement.
Some customers may still experience intermittent issues, and our engineering teams remain actively engaged in monitoring the environment and addressing any remaining impacts.
We will continue to provide updates as more information becomes available.
Posted Jul 30, 2026 - 00:32 UTC
Update
A fix has been implemented, and our systems continue to recover. We are seeing overall improvements in performance and stability, and services should be accessible and functioning normally for most customers.
While the situation has improved, some customers may still experience intermittent issues. Our teams are continuing to closely monitor system performance and stability and are actively working to address any remaining impacts.
This remains our team's top priority, and we will continue to provide updates as more information becomes available.
Posted Jul 29, 2026 - 20:48 UTC
Monitoring
A fix has been implemented. Our systems are recovering, and we are now closely monitoring performance and stability to ensure the issue is fully resolved.
Services should now be accessible and functioning normally.
Posted Jul 29, 2026 - 19:24 UTC
Update
Our teams are making steady progress in addressing the resource constraints and improving overall performance. We continue to closely monitor the environment while the remaining improvements are being worked through.
We will share further updates as the work continues.
Posted Jul 29, 2026 - 14:41 UTC
Update
Our teams continue to actively work on addressing the identified resource constraints and implementing improvements to enhance performance and stability. The environment remains under close monitoring while these efforts are ongoing.
This remains a top priority, and we will provide further updates as progress is made.
Posted Jul 29, 2026 - 06:29 UTC
Identified
We have identified resource constraints that are contributing to the performance issues. To address these findings, we are implementing additional improvements as part of an upcoming release. Our teams remain actively engaged in monitoring the environment and working to improve performance and stability. This remains our team's top priority, and we will continue to provide updates as more information becomes available.
Posted Jul 29, 2026 - 00:33 UTC
Update
We are continuing to investigate this issue.
Posted Jul 28, 2026 - 23:30 UTC
Investigating
We are currently investigating reports of degraded performance affecting Conga Contracts within the NA region.
Customers may experience intermittent errors and slow performance.
We will provide further updates as they are available.
Posted Jul 28, 2026 - 20:24 UTC
This incident affects: Conga Legacy Products - North America (NA) (Conga Contracts - NA).