Investigating Issue Impacting Turbo Product

Incident Report for Conga

Resolved

The issue impacting Turbo Product in the EU region has been fully resolved and all affected systems have returned to normal operation.
Posted Jul 15, 2026 - 23:48 UTC

Monitoring

Our systems are recovering, and we are now closely monitoring performance and stability to ensure the issue is fully resolved.

Users should see performance returning to normal.
Posted Jul 15, 2026 - 23:36 UTC

Investigating

We are currently investigating an issue Turbo Production tenants in EU region.

Customers may experience intermittent service disruptions and degraded application performance.

We will provide further updates as they become available.
Posted Jul 15, 2026 - 23:26 UTC
This incident affected: Conga Legacy Products - EMEA (EU) (Turbo Search Service - EU, Turbo Pricing Service - EU, Turbo Config Service - EU).