Conga Advantage platform along with other Conga Services are down due to Cloudflare global outage

Incident Report for Conga

Resolved

We have confirmed that the upstream Cloudflare network issues are resolved. We have monitored our systems for the last 20 minutes, and all automated tests and health checks are passing.
Posted Nov 18, 2025 - 15:26 UTC

Monitoring

Cloudflare has confirmed that a fix has been implemented for the global network issues. We are observing a return to normal operation across all Conga services.

We are continuing to monitor while we verify full stability and performance across the platform.
Posted Nov 18, 2025 - 14:57 UTC

Update

We have successfully recovered the Conga Contracts service, and it is now fully operational.

Our team is currently executing a temporary restoration strategy to bring Turbo Services back online. You may continue to experience intermittent availability with Turbo Services while this process is underway.

We remain in a monitoring state as we track the ongoing global Cloudflare outage and will provide further updates as services stabilize.

Cloudflare Status: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 14:08 UTC

Update

Our services are currently experiencing intermittent connectivity issues due to the ongoing Cloudflare incident.

We are seeing some successful traffic throughput and are monitoring the situation closely as Cloudflare continues their remediation. You may experience occasional timeouts or errors while the global network stabilizes.
Posted Nov 18, 2025 - 13:53 UTC

Update

Due to the widespread Cloudflare network issues, several of our services have experienced interruptions. We have successfully restored access to the Merge Service and OCC.

We are monitoring the situation closely and will continue to provide updates.
Posted Nov 18, 2025 - 13:45 UTC

Identified

Conga Advantage platform along with other Conga Services are down due to Cloudflare global outage, this issue is impacting all the Conga services in all the regions (North America, EMEA and APAC)
(https://www.cloudflarestatus.com/incidents/8gmgl950y3h7)

Customers may continue to experience inability to access conga services while the fix is being deployed from cloudflare.
Posted Nov 18, 2025 - 12:13 UTC
This incident affected: Document Automation - North America (NA) (Conga Composer - NA, Conga Batch - NA, Conga Trigger - NA, Conga Collaborate - NA, Composer API - NA, Conga Sign - NA, High Volume Merge - NA), Document Automation - EMEA (EU) (Conga Composer - EU, Conga Batch - EU, Conga Trigger - EU, Conga Collaborate - EU, Composer API - EU, Conga Sign - EU, High Volume Merge - EU), Document Automation - APAC (AP) (Conga Composer - AP, Conga Batch - AP, Conga Trigger - AP, Conga Collaborate - AP, Composer API - AP, Conga Sign - AP, High Volume Merge - AP), Revenue Lifecycle Management - North America (NA) (CPQ Catalog Service - NA, CPQ Config Service - NA, CPQ Pricing Service - NA, CPQ Administration Service - NA, CPQ Assets Service - NA, CPQ Renewals Service - NA, CPQ Quote Service - NA, CPQ Order Service - NA), Revenue Lifecycle Management - EMEA (EU) (CPQ Catalog Service - EU, CPQ Config Service - EU, CPQ Pricing Service - EU, CPQ Administration Service - EU, CPQ Assets Service - EU, CPQ Renewals Service - EU, CPQ Quote Service - EU, CPQ Order Service - EU), Revenue Lifecycle Management - APAC (AP) (CPQ Catalog Service - AP, CPQ Config Service - AP, CPQ Pricing Service - AP, CPQ Administration Service - AP, CPQ Assets Service - AP, CPQ Quote Service - AP, CPQ Order Service - AP), Contract Lifecycle Management - North America (NA) (Conga CLM - NA, Conga CLM for Salesforce - NA, Conga Contracts for Salesforce - NA, Conga Contracts Legacy - NA, Merge Service - NA, X-Author for Contracts - NA, Discovery AI - NA, Conga CLM for Salesforce Smart Search - NA), Contract Lifecycle Management - EMEA (EU) (Conga CLM - EU, Conga CLM for Salesforce - EU, Conga Contracts for Salesforce - EU, X-Author for Contracts - EU, Merge Service - EU, Discovery AI - EU, Conga CLM for Salesforce Smart Search - EU), Contract Lifecycle Management - APAC (AP) (Conga CLM - AP, Conga CLM for Salesforce - AP, Conga Contracts for Salesforce - AP, X-Author for Contracts - AP, Merge Service - AP, Discovery AI - AP, Conga CLM for Salesforce Smart Search - AP), Conga Legacy Products - North America (NA) (Conga Contracts - NA, Conga Contract Intelligence - NA, Conga Sign Professional - NA, Merge Service Legacy - NA, Online Contract Collaboration - NA, Smart Search (CLM) - NA, Turbo Search Service - NA, Turbo Pricing Service - NA, Turbo Config Service - NA, X-Author Legacy - NA), Advantage Platform Shared Services - North America (NA) (Login & Authentication - NA), Conga Legacy Products - EMEA (EU) (Conga Contracts - EU, Conga Contract Intelligence - EU, Conga Sign Professional - EU, Merge Service Legacy - EU, Online Contract Collaboration - EU, Smart Search (CLM) - EU, Turbo Search Service - EU, Turbo Pricing Service - EU, Turbo Config Service - EU, X-Author Legacy - EU), Conga Legacy Products - APAC (AP) (Conga Contracts - AP, Conga Contract Intelligence - AP, Conga Sign Professional - AP, Merge Service Legacy - AP, Online Contract Collaboration - AP, Smart Search (CLM) - AP, Turbo Search Service - AP, Turbo Pricing Service - AP, Turbo Config Service - AP, X-Author Legacy - AP), Advantage Platform Shared Services - EMEA (EU) (Login & Authentication - EU), Advantage Platform Shared Services - APAC (AP) (Login & Authentication - APAC (AP)), Document Automation - France (FR) (Conga Composer - FR, Conga Batch - FR, Conga Trigger - FR, Conga Collaborate - FR, Composer API - FR, Conga Sign - FR, High Volume Merge - FR), Revenue Lifecycle Management - France (FR) (CPQ Catalog Service - FR, CPQ Config Service - FR, CPQ Pricing Service - FR, CPQ Administration Service - FR, CPQ Assets Service - FR, CPQ Quote Service - FR, CPQ Order Service - FR), Contract Lifecycle Management - France (FR) (Conga CLM - FR, Conga CLM for Salesforce - FR, Conga Contracts for Salesforce - FR, X-Author for Contracts - FR, Merge Service - FR, Discovery AI - FR, Conga CLM for Salesforce Smart Search - FR), Advantage Platform Shared Services - France (FR) (Login & Authentication - FR), and Conga Dependencies (Cloudflare).